No Column Formatting in List View Webparts? No problem!

Posted by: Joy Turner on September 11, 2018

OK, guys and gals, I’m sure you disagree with the title and that’s alright because it is a problem. A rather big one. But, I have a workaround to offer you until Microsoft catches up with the demand for functionality in our list view webparts 

The situation 

I have a client that needs a few list view webparts (LVWP) for 3 different lists, on a single page. One of these lists has a Flow attached to it. A user clicks the magic “Copy” button and that list item is copied to another list. The Flow works great in the list. Not in the LVWP. Here it is below: 

SharePoint - No Column Formatting in List View Webparts

The Copy button is there but it’s in GNDN mode: Goes Nowhere Does Nothing. Notice, I don’t even have the full list toolbar in the webpart so I can’t select the item and use the Flow dropdown that our lists and libraries have on the root page.

What to do…?

Embed!

SharePoint - No Column Formatting in List View Webparts

 

 

Instead of using the LVWP (for now. Right Microsoft?) use the Embed webpart.

Paste the URL of your list into the “Website address or embed code” text area and you’re good to go!

 

SharePoint - No Column Formatting in List View Webparts

When I save the page, I now have a more functional window into my list. I can now click the “Copy to Visitor” and have the workflow run from the page.

SharePoint - No Column Formatting in List View Webparts

I’m not thrilled at the horizontal scroll situation but I’m typically a fan of having a “Reader’s Digest” version of our lists and libraries in webparts on pages so that’s what I’ll set up here.

Once our list view library webparts support column formatting (right, Microsoft?) it’ll be an easy task to switch this one out. Until then, Embed is the way to go.

Recent Posts

Categories